Bienvenido, Invitado
Nombre de Usuario: Contraseña:

TEMA: Problemas con el templates

Problemas con el templates 4 años 7 meses antes #6731

  • ivett
  • Avatar de ivett
  • Fuera de línea
  • Fresh Boarder
  • Mensajes: 3
  • Karma: 0
Hola a toda la comunidad,

Por favor necesito su ayuda, soy nueva con joomla,estoy empezando a crear mi plantilla.. al momento de vincular mi template con mi index.php, deberia verse los estilos definidos por el template pero no se visualiza los cambios..
en el index.php tengo el codigo siguiente

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="www.w3.org/1999/xhtml">
<head>
<jdoc:include type="head" />
<link href="css/template1.css" rel="stylesheet" type="text/css" />
<link rel="stylesheet" href="templates/<?php echo $this->template ?>/css/template.css"
type="text/css" />
</head>

OJO: Tengo dos templates el template1.css es donde se encuentran mis estilos, template.css
es el template q me vino por default, ya q estoy trabajando con un template base.


Espero q me puedan ayudar.
saludos
Última Edición: 4 años 7 meses antes por ivett.
El administrador ha desactivado la escritura pública.

Re: Problemas con el templates 4 años 7 meses antes #6754

  • hector_scl
  • Avatar de hector_scl
  • Fuera de línea
  • Moderator
  • Mensajes: 273
  • Gracias recibidas 23
  • Karma: 6
Hola!

Como sugerencia, toma tus estilos e incluyelos en el archivo template.css

Quizás debas reemplazar algunos estilos que ya están definidos, por lo que te recomiendo hacer un respaldo del archivo antes de los cambios... Una vez que apliques los cambios, los subes a tu sitio web y actualizas.

Comentanos como te va con eso!


Saludos,
Héctor
Hector Mansilla Arias
Moderador
Foro Joomla Chile
El administrador ha desactivado la escritura pública.




Re: Problemas con el templates 4 años 7 meses antes #6755

  • ivett
  • Avatar de ivett
  • Fuera de línea
  • Fresh Boarder
  • Mensajes: 3
  • Karma: 0
Te comento que me ocurrio algo curioso la codificacion estaba usando de esta manera

<link href="css/template1.css" rel="stylesheet" type="text/css" />
<link rel="stylesheet" href="templates/<?php echo $this->template ?>/css/template.css" type="text/css" />

Pero de tantas veces q lo intente hice una prueba y lo inverti, dando como resultado:

<link rel="stylesheet" href="templates/<?php echo $this->template ?>/css/template.css" type="text/css" />
<link href="css/template1.css" rel="stylesheet" type="text/css" />

Y funciono perfectamente, la verdad no se el porque pero esta funcionando. Para mi logica deberia ser como estaba inicialmente para tener como prioridad el templade1.

Muchas gracias por tu ayuda saludos
El administrador ha desactivado la escritura pública.




Re: Problemas con el templates 4 años 7 meses antes #6760

  • hector_scl
  • Avatar de hector_scl
  • Fuera de línea
  • Moderator
  • Mensajes: 273
  • Gracias recibidas 23
  • Karma: 6
<head><link href= type=text/css rel=stylesheet></head>
Hector Mansilla Arias
Moderador
Foro Joomla Chile
El administrador ha desactivado la escritura pública.
Tiempo de carga de la página: 0.210 segundos
Gracias a Foro Kunena