Bienvenido, Invitado
Nombre de Usuario: Contraseña:

TEMA: problema con plugins de seguridad hack

problema con plugins de seguridad hack 5 años 5 meses antes #5035

  • Borismiranda
  • Avatar de Borismiranda
  • Fuera de línea
  • Senior Boarder
  • Mensajes: 44
  • Gracias recibidas 1
  • Karma: 3
Maestros

instalé el plugins jHackGuard, para joomla 1.5 y cuando lo estaba cargando aparecio este error

Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /home/mi000302/public_html/plugins/system/jhackguard.php on line 45

al descargar este archivo para ver de que se trata la linea 45 dice

43 class plgSystemjhackguard extends JPlugin {
44
45 private $pluginParams;
46 private $log;
47
48 function plgSystemjhackguard(&$subject) {
49 parent::__construct($subject);
50
51 // load plugin parameters
52 $plugin = &JPluginHelper::getPlugin('system', 'jhackguard');
53 $this->pluginParams = new JParameter($plugin->params);
54 $this->log = &JLog::getInstance($this->pluginParams->get('log_file'));
55 }

se que puedo borrar manualmente los archivos y todo sera normal, pero quiero saber de que se trata, no entiendo mucho de PHP, ¿que se hace en estos casos?

NOS VEMOS EN EL JOOMLA!NIGHT
El administrador ha desactivado la escritura pública.

Re: problema con plugins de seguridad hack 5 años 5 meses antes #5043

  • willin
  • Avatar de willin
  • Fuera de línea
  • Administrator
  • Cuidado! Ya no estoy solo...
  • Mensajes: 1897
  • Gracias recibidas 44
  • Karma: 67
Hola Boris!

Colega, la verdad es que no conocía ese plugin, así es que me tomaré el fin de semana para instalarlo y revisarlo, luego te comento el resultado.

Un cordial saludo,
Guillermo Bravo
Administrador
Foro Joomla Chile
El administrador ha desactivado la escritura pública.




Tiempo de carga de la página: 0.150 segundos
Gracias a Foro Kunena