Bienvenido, Invitado
Nombre de Usuario: Contraseña:
  • Página:
  • 1
  • 2

TEMA: MENU ACTIVE O CURRENT NO ME FUNCIONA

MENU ACTIVE O CURRENT NO ME FUNCIONA 01 Abr 2011 06:03 #4345

  • m79
  • Avatar de m79 Autor del tema
  • Fuera de línea
  • Senior Boarder
  • Senior Boarder
  • Mensajes: 71
  • Karma: 1
  • Gracias recibidas 0
Hola comunidad, les cuento que estoy trabajando en un menú y necesito que los botones se muestren activos con current al momento de estar en la sección, categoría o articulo correspondiente del sitio, con mi código solo queda activo el botón numero uno (home) en todos los contenidos del sitio, el botón que se activa en este caso es el que dice "home" se ve activo en todos lados, después siguen otros que no se activan donde corresponde y solo se ve activo el primero.

La verdad es que ya no se que estaré haciendo mal y les pido ayuda, de antemano muchas gracias.

La versión de joomla del sitio que me pidieron arreglar es la 1.4.14

Mi código:

/* menu pie de pagina */

#menu_footer {
margin: 0px;
width: 760px;
padding: 0px;
height: 20px;
padding-top: 45px;
padding-right: 35px;
padding-bottom: 45px;
padding-left: 35px;
}

#menu_footer ul {
list-style:none;
margin: 0px;
padding: 0px;
}

#menu_footer li {
margin: 0px;
padding: 0px;
float: left;
list-style-image: none;
list-style-type: none;
}

#menu_footer ul.menu li a {
border-left-style: solid;
border-left-color: #7A7B6D;
border-left-width: 1px;
color: #C0B48A;
text-decoration: none;
font-weight: bold;
font-variant: small-caps;
letter-spacing: 0.2em;
font-size: 12px;
display:block;
padding-top: 3px;
padding-right: 6px;
padding-bottom: 3px;
padding-left: 6px;
}

#menu_footer ul.menu li a:hover,
#menu_footer ul.menu li:active {
width: auto;
text-decoration: none;
color: #FFF;
}

/*ESTO NO ME FUNCIONA*/

li#current a {
color: #FFF !important;
}

/*ESTO TAMPOCO ME FUNCIONA*/

#menu_footer ul li.active a{
width: auto;
text-decoration: none;
color: #FFF;
}

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Última Edición: por m79.

Re: MENU ACTIVE O CURRENT NO ME FUNCIONA 01 Abr 2011 15:26 #4347

Puedes poner la dirección del sitio para echarle un ojo?

Saludos.

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Daniel Martinez
Moderador
Comunidad Joomla Chile




Re: MENU ACTIVE O CURRENT NO ME FUNCIONA 01 Abr 2011 16:48 #4351

  • m79
  • Avatar de m79 Autor del tema
  • Fuera de línea
  • Senior Boarder
  • Senior Boarder
  • Mensajes: 71
  • Karma: 1
  • Gracias recibidas 0
Te puedo mandar el link por correo ?

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Re: MENU ACTIVE O CURRENT NO ME FUNCIONA 04 Abr 2011 03:35 #4374

Hola,

Partiendo de que para declarar una posición para el menú puedes hacerlo con (index.php):
<div id="menu-footer">
<jdoc:include type="modules" name="menu" style="XHTML" />
</div>

Y que en esa posición tengas un módulo del tipo mod_mainmenu del tipo "lista" y con un sufijo de clase menu "_footer" puedes diferenciar el item de menú activo de esta forma por ejemplo (template.css):
.menu_footer li.active a {
color: red;
}

Espero que te sirva, saludos.

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Daniel Martinez
Moderador
Comunidad Joomla Chile
Última Edición: por danylocl.

Re: MENU ACTIVE O CURRENT NO ME FUNCIONA 05 Abr 2011 01:41 #4382

  • m79
  • Avatar de m79 Autor del tema
  • Fuera de línea
  • Senior Boarder
  • Senior Boarder
  • Mensajes: 71
  • Karma: 1
  • Gracias recibidas 0
gracias danyocl, la verdad que con tu código y los que yo ya tenia son correctos, mi problema es de joomla, o joomfish o que el sitio llama al dominio .cl y .com al mismo tiempo, estoy craneando que el current o active no marque solo un botón en todos los contenidos...... son de esas panas extrañas

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Re: MENU ACTIVE O CURRENT NO ME FUNCIONA 05 Abr 2011 03:09 #4383

Sí, por lo que estuve revisando el código que genera el index.php no se corresponde con lo que debería salir por eso no coge los estilos .css

Puedes poner una parte del index.php por aqui?

Saludos.

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Daniel Martinez
Moderador
Comunidad Joomla Chile
  • Página:
  • 1
  • 2
Tiempo de carga de la página: 0.381 segundos
Gracias a Foro Kunena