Bienvenido, Invitado
Nombre de Usuario: Contraseña:
  • Página:
  • 1
  • 2

TEMA: no se ven los menus en mi plantilla

no se ven los menus en mi plantilla 10 Oct 2011 00:42 #5756

  • rocodocoromro
  • Avatar de rocodocoromro Autor del tema
  • Fuera de línea
  • Fresh Boarder
  • Fresh Boarder
  • Mensajes: 4
  • Gracias recibidas 0
Hola primero que nada gracias que existen estos foros y encomiendo en ustedes mi corazón porque no he encontrado respuesta a mi problema.

Hice una plantilla desde cero de practica con unos tutos que encontré y todo bien y la instalación bien, el problema es que al crear el menú no se vé jamás se ve inclusive si uso menús de joomla.

El menú lo creo de la sig. forma:

-creo categoría
-creo artículo para esa categoría
-creo menu
-creo ítem de ese menú que enlaza a al artículo de mi categoría
-y creo modulo que enlaza a mi menú y en la posición que le asigno de mi plantilla

y nada de nada todo se sigue viendo correcto pero vacío sin ningún menú. Ya probé varias posiciones de mi plantilla inclusive con menus de los que trae joomla y nada, ya seguí varios tutos y en ninguno veo nada fuera de lo normal o distinto a lo que hago y les sale sin problema y a mi nada, sól una cosa en los tutos siempre usan generadores de plantillas ya sea dreamwebwer o cualquier otro, yo lo hice todo con el notepad.

que me falta por favor me voy a dar porvencido con joomla y seguiré con css y html ya busque por una semana y el día de hoy le busque desde las 10 de la mañana hasta ahorita y nada. Anexo a continuación mi codigo:

index.php
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="<?php echo $this->language; ?>" lang="<?php echo $this->language; ?>" >
<head>
<jdoc:include type="head" />
  <link rel="stylesheet" href="<?php echo $this->baseurl ?>/templates/<?php echo $this->template ?>/css/template.css" type="text/css" />
</head>

<body>
<div id="contenedor">
<div id="header"><jdoc:include type="modules" name="top" /></div>

<div id="sidebar-left"><div class="moduletable_menu"><jdoc:include type="modules" name="left"/></div></div>
<div class="contenido">
<jdoc:include type="component" />
</div>
<div id="sidebar-right"><jdoc:include type="modules" name="right"/></div>

<div id="footer" class="clear">este es el apestoso pie</div>

</div>


</body>
</html>

template.css
body {   
background : url(../images/fondo.jpg) repeat; 
font : 8pt Verdana, Geneva, Arial, Helvetica, sans-serif; 
color : #666666; 
margin : 20px 0px 20px 0px; 
text-align: center; 
}

#contenedor{ 
text-align: left; 
width: 1000px;
overflow:auto;
background-color : #ffffff; 
margin: auto; 
border: 2px groove green; 
}


#header{ 
background: url(../images/banner.jpg) no-repeat; 
width: 1000px; 
height: 100px;
float: left;
}

.contenido{  
width:450px;
overflow: auto;
padding: 0px 0px 0px 0px;
background-color : #ffccff;
float: left; 
}



#sidebar-left{
width: 250px;
height: 400px;
background-color: red;
border-left : 1px solid #cccccc;
float: left;
}

#sidebar-right{
width: 250px;
height: 400px;
background-color: red;
border-left : 1px solid #cccccc;
float: right;
}

#footer{
width: 800px;
background-color: #223355;
color: #ffffff;
text-align: center;
float: left;
}

templateDetails.xml
<?xml version="1.0" encoding="utf-8"?>
<!DOCTYPE install PUBLIC "-//Joomla! 1.7//DTD template 1.0//EN"
"http://dev.joomla.org/xml/1.7/template-install.dtd">

<install version="1.7" type="template">

<name>primera</name>
<creationDate>05-10-2011</creationDate>
<author>yo</author>
<authorEmail>mimail@gmail.com</authorEmail>
<authorUrl>http://localhost</authorUrl>
<copyright>spc 2011</copyright>
<license>GNU/GPL</license>
<version>1.0.0</version>
<description>template de prueba numero 20 para ver como me sale</description>

<files>
<filename>index.php</filename>
<filename>templateDetails.xml</filename>
<filename>css/template.css</filename>
<filename>images/banner.jpg</filename>
<filename>images/fondo.jpg</filename>
<filename>images/fondonav.gif</filename>
</files>

<positions>
<position>top </position>
<position>left </position>
<position>right </position>
<position>footer </position>
</positions>

</install>

ayuda por favor en verdad ya casi lloro. gracias :(

aqui mi plantilla

Adjuntos:

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Última Edición: por rocodocoromro. Razón: tamaño de imagen

Re: no se ven los menus en mi plantilla 13 Oct 2011 00:23 #5767

  • willin
  • Avatar de willin
  • Fuera de línea
  • Administrator
  • Administrator
  • Cuidado! Ya no estoy solo...
  • Mensajes: 1897
  • Karma: 67
  • Gracias recibidas 44
Hola rocodocoromro!

Colega, a falta de firebug en la imagen, sería posible que me enviaras la plantilla para instalarla en local y probarla?

Atento a tus comentarios, recibe un cordial saludo,

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Guillermo Bravo
Administrador
Foro Joomla Chile




Re: no se ven los menus en mi plantilla 18 Oct 2011 00:19 #5821

  • rocodocoromro
  • Avatar de rocodocoromro Autor del tema
  • Fuera de línea
  • Fresh Boarder
  • Fresh Boarder
  • Mensajes: 4
  • Gracias recibidas 0

Archivo Adjunto:

Nombre del Archivo: primera.zip
Tamaño del Archivo: 2 KB

hola, muchas gracias. Te anexo la plantilla. Perdón pero ya la estuve modificando varias veces y ya no se si esta ultima está completamente como la primera. Hay una cosa rara: si le pongo las posiciones de las plantillas de joomla por ejemplo la atomic-sidebar si me aparece en mi div (claro modificando mi index y mi xmldetails)los modulos k quiera, y en ese caso le agrego id's a los menús en joomla y luego los edito en mi css y va como estoy queriendo, pero así como que es mi plantilla y mis pocisiones y todo mío y mis nuevos modulos en joomla que haga pues nomás "naranjas" osea, nada de nada jeje. Saludos.

huy el foro no me dejó subir el zip. mmm te anexo my css index y xml las imágenes no porque me dice el form k exedo lo permitido, como quiera sólo son de relleno.
Adjuntos:

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Última Edición: por rocodocoromro. Razón: no deja subir nada

Re: no se ven los menus en mi plantilla 22 Oct 2011 03:26 #5853

  • willin
  • Avatar de willin
  • Fuera de línea
  • Administrator
  • Administrator
  • Cuidado! Ya no estoy solo...
  • Mensajes: 1897
  • Karma: 67
  • Gracias recibidas 44
Hola rocodocoromro!

Colega, he estado un poco desconectado, me podrías indicar como va el tema del menú, si no para revisar la plantilla que me enviaste :)

Atento a tus comentarios, recibe un cordial saludo,

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Guillermo Bravo
Administrador
Foro Joomla Chile

Re: no se ven los menus en mi plantilla 29 Oct 2011 01:59 #5939

  • rocodocoromro
  • Avatar de rocodocoromro Autor del tema
  • Fuera de línea
  • Fresh Boarder
  • Fresh Boarder
  • Mensajes: 4
  • Gracias recibidas 0
hola no habia tenido chance re revisar. Primero muchas gracias por responder. Pues me di casi por vencido no lo he resuelto, aunque sigo usando las posiciones de las plantillas que ya trae joomla en mi xml y css y combinadas con mi plantilla y raro que asi si se pueda. Pero si creo que seria una gran ayuda si las revisaras y me dieras una pista de por donde me pierdo tanto :( . Gracias otra vez.

saludos :)

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Última Edición: por rocodocoromro. Razón: me falto poner completo

Re: no se ven los menus en mi plantilla 31 Oct 2011 21:08 #5959

  • willin
  • Avatar de willin
  • Fuera de línea
  • Administrator
  • Administrator
  • Cuidado! Ya no estoy solo...
  • Mensajes: 1897
  • Karma: 67
  • Gracias recibidas 44
Hola rocodocoromro!

Colega, te adjunto la plantilla con unas pequeña modificación... Le agregu´`e la posición al templateDetails.xml :)

Atento a tus comentarios, recibe un cordial saludo,

Archivo Adjunto:

Nombre del Archivo: primera_2011-10-31-2.zip
Tamaño del Archivo: 2 KB


El mensaje anterior lo eliminé, porque me había equivocado de zip :blush:
Adjuntos:

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Guillermo Bravo
Administrador
Foro Joomla Chile
  • Página:
  • 1
  • 2
Tiempo de carga de la página: 0.413 segundos
Gracias a Foro Kunena